Timeouts when performing authentication
Incident Report for Duo
Postmortem

On April 13, 2015, customers using Duo Security's authentication service experienced intermittent authentication issues lasting 54 minutes due to an issue with one of our primary load balancers. The result of the issue was a series of authentication timeouts. After a failover event, the load balancer issues concluded and users were able to authenticate as usual.

We sincerely apologize for this incident and want to reiterate that we take service reliability very seriously. Please be assured that high-availability access to our systems is a top priority at Duo Security, and we will continue to make improvements to our product to ensure the best customer experience.

Posted Apr 14, 2015 - 16:25 EDT

Resolved
Due to performance issues with several of our load balancers today, some users encountered intermittent network timeouts resulting in authentication errors. The root issue has been identified and resolved and further information will be made available following a thorough investigation.
Posted Apr 13, 2015 - 17:04 EDT
Monitoring
Duo's Operations Team has identified the issue and put a fix in place. User authentication should be functioning as normal. We will continue monitoring the issue while Ops investigates the root cause.
Posted Apr 13, 2015 - 12:07 EDT
Investigating
Our operations team is actively investigating reports from customers regarding authentication issues.
Posted Apr 13, 2015 - 11:52 EDT